Author Topic: problem with Ramp Script!  (Read 577 times)

shane_Iron

  • Newbie
  • *
  • Posts: 25
  • Karma: +3/-15
  • I LOVE NY
    • View Profile
    • Shane Iron
problem with Ramp Script!
« on: November 07, 2016, 03:47:14 pm »
[EN/ES]GTM:clan-wars!hi I need help i don't know that how to run ramp script in my server!
can anyone help me for this script if you help i will be very thankfull to you
 
regards,
          Shane

Theremin

  • Full Member
  • ***
  • Posts: 152
  • Karma: +48/-17
  • Worst Server Owner
    • View Profile
    • Visit my YouTube channel
Re: problem with Ramp Script!
« Reply #1 on: November 07, 2016, 06:03:04 pm »
What's the problem exactly? Explain more in detail

shane_Iron

  • Newbie
  • *
  • Posts: 25
  • Karma: +3/-15
  • I LOVE NY
    • View Profile
    • Shane Iron
Re: problem with Ramp Script!
« Reply #2 on: November 08, 2016, 10:26:47 am »
What's the problem exactly? Explain more in detail

i copy The Ramp script to Script>Ramps!
and i type this in content.xml <script folder="ramps" />
and now i don't know what i do now  :(
!!!
Please help this!
« Last Edit: November 08, 2016, 10:40:31 am by shane221 »

Theremin

  • Full Member
  • ***
  • Posts: 152
  • Karma: +48/-17
  • Worst Server Owner
    • View Profile
    • Visit my YouTube channel
Re: problem with Ramp Script!
« Reply #3 on: November 10, 2016, 02:10:17 pm »
can someone help me I can get the script in but I cant get it to run on my server someone please help.

*Huge Bump*

For all the ones who have problems with this script (and with every other old script that calls server functions from the client) remember that since 0.15 version for security reasons you must register server functions before calling them from client scripts, else they won't work.

More info here: http://liberty-unleashed.co.uk/LUWiki/Squirrel/Server/Functions/Scripts/RegisterRemoteFunc

To "fix" this script add the following in your server scripts:
Code: [Select]
RegisterRemoteFunc("SpawnRamp");
RegisterRemoteFunc("VehicleBoost");

TurboGrafx

  • Full Member
  • ***
  • Posts: 230
  • Karma: +32/-31
    • View Profile
Re: problem with Ramp Script!
« Reply #4 on: November 10, 2016, 02:52:51 pm »
Yeah when I returned to LU I had this issue.

http://forum.liberty-unleashed.co.uk/index.php/topic,2565.msg13769.html#msg13769



RegisterRemoteFunc

Will be used on server event that are related on client bind key events

Hear is a better example for you than what someone provided in the wiki

Code: [Select]
/* Client script */

pPlayer <- FindLocalPlayer();

function onScriptLoad()
{
     print("Bind key added 'i'")
     BindKey( 'I', BINDTYPE_DOWN, "ClientFunction" );
}

function ClientFunction()
{
     /* Lets make a call to our server function */
     // located inside of our script folder
     CallServerFunc( "Server/Server.nut", "ServerFunction", pPlayer );
}


Code: [Select]
/* Server script */

function onScriptLoad()
{
     // Lets register our client function
     RegisterRemoteFunc("ServerFunction");
}

function ServerFunction( player )
{
     MessagePlayer("Thank you for registering me", player);
}
« Last Edit: November 10, 2016, 02:54:31 pm by Mötley »

shane_Iron

  • Newbie
  • *
  • Posts: 25
  • Karma: +3/-15
  • I LOVE NY
    • View Profile
    • Shane Iron
Re: problem with Ramp Script!
« Reply #5 on: November 11, 2016, 12:42:23 pm »
i am really so noob at scripting i am sorry but i didn't explain can anyone send the file that you maked like this in ramp script and send it to
Quote
my Email
Quote
samik0170@gmail.com
Thanks in advance!
please send the modify ramps script !

 

© Liberty Unleashed Team.