Author Topic: Juppi's MySQL Module (lu_mysql)  (Read 13738 times)

stormeus

  • No-Lifer
  • Developer
  • Full Member
  • *****
  • Posts: 112
  • Karma: +13/-2
    • View Profile
Re: Juppi's MySQL Module (lu_mysql)
« Reply #30 on: July 21, 2013, 07:01:07 pm »
compiled in VS2008 Release build using the source code from Thijns dropbox link since i assume thats the most up to date source.

As long as it was made on or after 19 Nov. 2011, it should be fine. Anything before that is susceptible to errors when trying to select multiple rows.
Quote
Morphine says:
    them LU devs ranting about how LU doesn't have client pickups
    while us VC:MPers don't have client anything
    ;_;

Stormeus Argo says:
    we have client crashes though
    ohohohohoho

Morphine says:
    LU DOESN'T HAVE THAT

Stormeus Argo says:
    LU - 0
    VC:MP - 1

SugarD

  • Argonath RPG Dev/Manager
  • Tester
  • Sr. Member
  • ****
  • Posts: 817
  • Karma: +37/-74
  • STOP IN THE NAME OF THE COLESLAW!
    • View Profile
    • Clan Xperience
Re: Juppi's MySQL Module (lu_mysql)
« Reply #31 on: July 21, 2013, 07:06:43 pm »
I believe all the links in the Wiki and here have been updated. Whatever updated ones Stormeus posted to update them since, I updated on the Wiki too.

Yamaza

  • Newbie
  • *
  • Posts: 12
  • Karma: +2/-1
    • View Profile
Re: Juppi's MySQL Module (lu_mysql)
« Reply #32 on: August 14, 2013, 11:18:40 pm »
Sorry for the bump, but i have server problems with the lu_mysql.so for linux.

AN ERROR HAS OCCURED [getVarInfo: Could not retrieve UserData]

I put everything perfectly, indeed, on my pc works 100% but linux does not. I have tried all, apt-get update, upgrade, aptitude, reinstall the os... but nothing. Maybe i miss a lib or something. I use Debian 7 with the latest updates, same as MySQL.

SugarD

  • Argonath RPG Dev/Manager
  • Tester
  • Sr. Member
  • ****
  • Posts: 817
  • Karma: +37/-74
  • STOP IN THE NAME OF THE COLESLAW!
    • View Profile
    • Clan Xperience
Re: Juppi's MySQL Module (lu_mysql)
« Reply #33 on: August 15, 2013, 12:30:45 am »
Sorry for the bump, but i have server problems with the lu_mysql.so for linux.

AN ERROR HAS OCCURED [getVarInfo: Could not retrieve UserData]

I put everything perfectly, indeed, on my pc works 100% but linux does not. I have tried all, apt-get update, upgrade, aptitude, reinstall the os... but nothing. Maybe i miss a lib or something. I use Debian 7 with the latest updates, same as MySQL.
Ah yes. That very annoying, generic error. It happens on Windows, too, for a variety of reasons. Usually it's related to a database error, or a problem with the code.

Thijn

  • Tester
  • Sr. Member
  • ****
  • Posts: 531
  • Karma: +27/-16
    • View Profile
Re: Juppi's MySQL Module (lu_mysql)
« Reply #34 on: August 15, 2013, 06:07:36 pm »
Do doing print( LoadModule("lu_mysql") );

If that prints false, the module isn't loading properly.

Are you running 32 or 64 bit?
You might wanna try compiling the module on your own box.

Yamaza

  • Newbie
  • *
  • Posts: 12
  • Karma: +2/-1
    • View Profile
Re: Juppi's MySQL Module (lu_mysql)
« Reply #35 on: August 15, 2013, 06:41:07 pm »
Hi, Thijn. Returns false. I using x32-Bit.

IdkanYavuk X

  • Jr. Member
  • **
  • Posts: 91
  • Karma: +37/-36
  • Developer for The Newport Experience
    • View Profile
Re: Juppi's MySQL Module (lu_mysql)
« Reply #36 on: August 16, 2013, 07:16:26 am »
Sorry for the bump, but i have server problems with the lu_mysql.so for linux.

AN ERROR HAS OCCURED [getVarInfo: Could not retrieve UserData]

I put everything perfectly, indeed, on my pc works 100% but linux does not. I have tried all, apt-get update, upgrade, aptitude, reinstall the os... but nothing. Maybe i miss a lib or something. I use Debian 7 with the latest updates, same as MySQL.

So you want to use a .dll for linux...

Vortrex

  • Full Member
  • ***
  • Posts: 264
  • Karma: +53/-69
    • View Profile
Re: Juppi's MySQL Module (lu_mysql)
« Reply #37 on: August 16, 2013, 07:33:50 am »
So you want to use a .dll for linux...

Wrong

.DLL files are for Windows, and .SO files are for Linux.

IdkanYavuk X

  • Jr. Member
  • **
  • Posts: 91
  • Karma: +37/-36
  • Developer for The Newport Experience
    • View Profile
Re: Juppi's MySQL Module (lu_mysql)
« Reply #38 on: August 18, 2013, 11:16:41 pm »
So you want to use a .dll for linux...

Wrong

.DLL files are for Windows, and .SO files are for Linux.

I know that.... I was being sarcastic

stormeus

  • No-Lifer
  • Developer
  • Full Member
  • *****
  • Posts: 112
  • Karma: +13/-2
    • View Profile
Re: Juppi's MySQL Module (lu_mysql)
« Reply #39 on: August 19, 2013, 02:34:43 am »
Plugin updated.



Windows users do not need to re-download the module. Linux users who are using libmysqlclient16 (MySQL 5.1) and/or have not had any issues with the module do not need to update.

The problem with Debian 7 is that it was updated to use the MySQL 5.5 (libmysqlclient18) libraries instead of libmysqlclient16 as was done with earlier builds, and as a result, MySQL functions could not be linked at runtime.

A MySQL 5.5 version has been added for download. Anyone using MySQL 5.5 on Linux and has encountered issues loading the module is encouraged to use it.

MySQL 5.5 binary (Linux x86)
https://lu-modules.googlecode.com/files/lu_mysql55.linux.zip
« Last Edit: August 19, 2013, 02:37:24 am by stormeus »
Quote
Morphine says:
    them LU devs ranting about how LU doesn't have client pickups
    while us VC:MPers don't have client anything
    ;_;

Stormeus Argo says:
    we have client crashes though
    ohohohohoho

Morphine says:
    LU DOESN'T HAVE THAT

Stormeus Argo says:
    LU - 0
    VC:MP - 1

Yamaza

  • Newbie
  • *
  • Posts: 12
  • Karma: +2/-1
    • View Profile
Re: Juppi's MySQL Module (lu_mysql)
« Reply #40 on: August 19, 2013, 11:00:13 am »
Many thank you very much, stormeus, the module works perfectly now without any problem on. Thanks also to people who tried to help me in the problem, as SugarD, Thijn and Vortrex.

ZX_Lost_Soul

  • Newbie
  • *
  • Posts: 25
  • Karma: +1/-1
    • View Profile
Re: Juppi's MySQL Module (lu_mysql)
« Reply #41 on: October 24, 2013, 09:52:34 pm »
The module doesn't work at CentOS x64 :( (Could not retrieve UserData)

Can someone compile it for 64-bit linux?
My English is very poor, please try to understand me)

Juppi

  • Developer
  • Jr. Member
  • *****
  • Posts: 86
  • Karma: +3/-1
    • View Profile
    • Kuslahden alaste GTA:MP clan
Re: Juppi's MySQL Module (lu_mysql)
« Reply #42 on: October 24, 2013, 10:52:29 pm »
There's no 64bit LU server available so a 64bit module would be useless. You're probably missing some dependencies (make sure you have the 32bit versions installed). Try 'ldd lu_mysql.so', it should tell you what youre missing.

ZX_Lost_Soul

  • Newbie
  • *
  • Posts: 25
  • Karma: +1/-1
    • View Profile
Re: Juppi's MySQL Module (lu_mysql)
« Reply #43 on: October 25, 2013, 02:03:52 am »
Try 'ldd lu_mysql.so'
Code: [Select]
libmysqlclient.so.18 => not foundCan't it work with libmysqlclient.so.16 ?
I can't find libmysqlclient.so.18 for CentOS(
My English is very poor, please try to understand me)

Thijn

  • Tester
  • Sr. Member
  • ****
  • Posts: 531
  • Karma: +27/-16
    • View Profile
Re: Juppi's MySQL Module (lu_mysql)
« Reply #44 on: October 25, 2013, 12:52:36 pm »
Just symlink your libmysqlclient.so.16 to libmysqlclient.so.18

 

© Liberty Unleashed Team.