Author Topic: [SOLVED] 0.17 server doesn't work under Win7  (Read 1195 times)

Theremin

  • Full Member
  • ***
  • Posts: 154
  • Karma: +48/-18
  • Worst Server Owner
    • View Profile
    • Visit my YouTube channel
[SOLVED] 0.17 server doesn't work under Win7
« on: August 24, 2016, 12:26:39 am »
EDIT: Stoku found a temporary solution until the developers hopefully fix it for good, scroll down and go read his post.

This is kinda a repost that I'm doing just because the original post I wrote was in a unrelated thread, and here is the correct thread with a proper title. Still if you want to read the whole original topic I attached the link at the end of this post.

I'm not able to turn on the Windows server after the update. I tested with two different versions of Win 7, one x64 the other x86, same result. The server crashes under EVERY condition, removing scripts or modules makes no change.

My server.exe crashes with this reason:

Problem signature:
Event name problem: APPCRASH
Application name: Server.exe
Application version: 0.0.0.0
The timestamp of the application: 575c4d1f
The name of the module with the error: ntdll.dll
The version of the module with the error: 6.1.7601.18247
The time stamp module with the error: 521ea8e7
Exception code: c0000420
Offset exceptions: 000ce753
OS version: 6.1.7601.2.1.0.256.48
Language code: 1049
Additional information 1: b734
Additional information 2: b7345d20daeb8ecacfbe1abb9e323096
Additional information 3: 4f78
Additional information 4: 4f787531a27c091e8e723c3eab8f5988


UPD:
0.1.0.16 works perfect!


Mine gives me no reason, just it has stopped working
Btw, running Windows 7 Ultimate 64-bit


I found reason why cant work my server, what Windows LU server 0.1.0.17 = bugged. LU Server 0.1.0.17 can only work to Linux


The above quotes already show four different people having problems with Win7 and LU server, I'm quite sure that nobody owning Win7 is able to run it.

OP: http://forum.liberty-unleashed.co.uk/index.php/topic,2572.msg13840.html#msg13840
« Last Edit: September 08, 2016, 02:52:43 am by Theremin »

neocortex

  • Full Member
  • ***
  • Posts: 102
  • Karma: +10/-63
  • Fuhrer of C.R.C
    • View Profile
Re: 0.17 server doesn't work under Win7
« Reply #1 on: August 24, 2016, 08:41:21 am »
i can confirm thats true, my server also closes itself for no reason.

win 7 Home premium i have.

Bullseye SBT

  • Newbie
  • *
  • Posts: 14
  • Karma: +2/-0
    • View Profile
    • Bull Breed Forum
Re: 0.17 server doesn't work under Win7
« Reply #2 on: August 24, 2016, 12:56:37 pm »
Same issue, I'm running Win 7 Pro..
I have a mod that I started back in 2008, which is on & off, it's called Liberty City Secrets, I hope one day I find time to finish it :)

Liberty City Secrets

SugarD

  • Argonath RPG Dev/Manager
  • Tester
  • Sr. Member
  • ****
  • Posts: 817
  • Karma: +37/-72
  • STOP IN THE NAME OF THE COLESLAW!
    • View Profile
    • Clan Xperience
Re: 0.17 server doesn't work under Win7
« Reply #3 on: September 02, 2016, 05:02:38 pm »
Make sure you guys post these bugs on the Mantis with all of the information you provided here. This will help VRocker and the other Developers hunt down the cause.

TurboGrafx

  • Full Member
  • ***
  • Posts: 233
  • Karma: +32/-33
    • View Profile
Re: 0.17 server doesn't work under Win7
« Reply #4 on: September 02, 2016, 06:46:12 pm »
Make sure you guys post these bugs on the Mantis with all of the information you provided here. This will help VRocker and the other Developers hunt down the cause.

[Rant]
Sorry but SugarD Is Juppi still doing any work? As well Force, I'm sure Adtec is. Not too sure who all is actually still coding for LU.

*On topic
I have not received these errors in Linux, With the server.bin, As well server.exe. I just cant play the game due too the browser update.


For laughs Theremin could you try the server.exe in safe mode of windows? I know there is network issues with safemode, I'm just curious about the server not returning errors. And or a positive error led, It's just a what if suggestion.

Theremin

  • Full Member
  • ***
  • Posts: 154
  • Karma: +48/-18
  • Worst Server Owner
    • View Profile
    • Visit my YouTube channel
Re: 0.17 server doesn't work under Win7
« Reply #5 on: September 03, 2016, 02:59:34 pm »
The only one who has lately worked on it is AdTec. Alright Motley I'll try running it in safe mode and edit this post later, let's see what happens.

EDIT: It crashes even there :(
« Last Edit: September 03, 2016, 03:08:19 pm by Theremin »

SugarD

  • Argonath RPG Dev/Manager
  • Tester
  • Sr. Member
  • ****
  • Posts: 817
  • Karma: +37/-72
  • STOP IN THE NAME OF THE COLESLAW!
    • View Profile
    • Clan Xperience
Re: 0.17 server doesn't work under Win7
« Reply #6 on: September 03, 2016, 07:54:03 pm »
Beside the fact that many of the Developers are busy and do this for free for your enjoyment, many of you have continuously ridiculed, flamed, and doubted them from day one. Can you really blame them for not wanting to continue working on this project actively? The community has done nothing but give them **** for trying to care. If people would change their attitude, then they may feel the desire to become active once more.

Stoku

  • lck.gudio.eu
  • Full Member
  • ***
  • Posts: 254
  • Karma: +20/-2
  • Liberty City Killers
    • View Profile
    • Liberty City Killers (GTA3/VC Clan)
Re: 0.17 server doesn't work under Win7
« Reply #7 on: September 06, 2016, 11:01:04 pm »
Having the same issue. Deleting vehicles from content.xml helped for me.

Theremin

  • Full Member
  • ***
  • Posts: 154
  • Karma: +48/-18
  • Worst Server Owner
    • View Profile
    • Visit my YouTube channel
[SOLVED] 0.17 server doesn't work under Win7
« Reply #8 on: September 08, 2016, 02:51:19 am »
You sir, you are a fucking legend! ;)

Thanks man I finally solved this problem! I had to remove vehicles as you said, and pickups as well but it worked!

SugarD

  • Argonath RPG Dev/Manager
  • Tester
  • Sr. Member
  • ****
  • Posts: 817
  • Karma: +37/-72
  • STOP IN THE NAME OF THE COLESLAW!
    • View Profile
    • Clan Xperience
Re: [SOLVED] 0.17 server doesn't work under Win7
« Reply #9 on: September 09, 2016, 12:52:58 am »
Make sure you guys update any bug reports related to this with your findings! It will help the Developers fix it.

LUmtap

  • Newbie
  • *
  • Posts: 45
  • Karma: +4/-8
  • Check my YT channel!
    • View Profile
    • My YouTube channel -->> LUmtap
Re: [SOLVED] 0.17 server doesn't work under Win7
« Reply #10 on: February 11, 2017, 12:30:01 am »
my pc is a win10 in win7 ;;--;;

Claudiu_Stelist

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: [SOLVED] 0.17 server doesn't work under Win7
« Reply #11 on: February 24, 2017, 04:21:59 am »

 

© Liberty Unleashed Team.