Author Topic: Update 0.1.0.17 (14/06/2016)  (Read 14662 times)

VRocker

  • Liberty Unleashed Developer
  • Administrator
  • Full Member
  • ******
  • Posts: 342
  • Karma: +42/-15
    • View Profile
    • Madnight Software
Update 0.1.0.17 (14/06/2016)
« on: June 15, 2016, 12:01:59 am »
Liberty Unleashed 0.1 Update

Updates to Liberty Unleashed 0.1 have been released, they will be automatically applied the next time you restart your server browser, the following changes include:

  • General - Fixed another crash related to the BF injection
  • General - Fixed a crash when pressing tab in the chatbox
  • General - Fixed a crash with CallClientFunc
  • General - Fixed some memory overflows which caused client instability
  • Security - Fixed being able to bypass the LUID checks
  • Security - Fixed being able to join a server without actually joining it
  • Security - Secured the client against some known cheats and exploits
  • General - Optimised some code in both the client and server

Known Issues
  • Joining a server that has a 'handling.cfg' in the LU/data directory will cause clients to crash on join

NOTE
Windows XP is no longer supported. Nobody should be running Windows XP on the internet these days so please update your operating system.

The update requires the new client (which the browser should download) and a new server for any server hosters. The new client and server have been compiled using Visual Studio 2015, a new redistributable will be installed.
« Last Edit: June 15, 2016, 12:25:53 am by VRocker »


VRocker

  • Liberty Unleashed Developer
  • Administrator
  • Full Member
  • ******
  • Posts: 342
  • Karma: +42/-15
    • View Profile
    • Madnight Software
Re: Update 0.1.0.17 (14/06/2016)
« Reply #1 on: June 15, 2016, 12:14:20 am »
It's that important it's listed twice xD I'll remove the dupe


rwwpl

  • Full Member
  • ***
  • Posts: 125
  • Karma: +17/-6
  • LU-DM Team
    • View Profile
    • LU-DM Team
Re: Update 0.1.0.17 (14/06/2016)
« Reply #2 on: June 15, 2016, 09:09:48 am »
Code: [Select]
You don't have permission to access /Downloads/lu-0.1-installer.zip on this server.
?

TeamSP13

  • Newbie
  • *
  • Posts: 6
  • Karma: +4/-0
    • View Profile
Re: Update 0.1.0.17 (14/06/2016)
« Reply #3 on: June 15, 2016, 11:52:41 am »
Maybe i'm inattentive, but did you do something with crashes via spawning boats?

sasha19323

  • Jr. Member
  • **
  • Posts: 99
  • Karma: +25/-24
    • View Profile
Re: Update 0.1.0.17 (14/06/2016)
« Reply #4 on: June 15, 2016, 01:09:23 pm »
  • Security - Secured the client against some known cheats and exploits

Nope, exploit still works.

I ain't checked other stuff, bcs i can't even join any server properly.

First of all, Linux server on x64 machine doesn't run:
Code: [Select]
version `CXXABI_1.3.8' not foundStackOverflow says, that you had to set -static-libstdc++ and -static-libgcc flags.

Windows server crashes, if there's some modules loaded.
No idea why it crashes.

And about client side...
Updating via LU browser didn't work properly for me, so i had to use this for update, but new browser doesn't work, so i still use .16 version.

After downloading server and client stuff, i tried to join my server. First, what i've found, that client crashes, if server uses sprites. I'll check other things later, but I guess everything I wrote above is enough.
« Last Edit: June 15, 2016, 01:31:28 pm by sasha19323 »

Ankris

  • Full Member
  • ***
  • Posts: 110
  • Karma: +29/-44
    • View Profile
Re: Update 0.1.0.17 (14/06/2016)
« Reply #5 on: June 15, 2016, 03:24:59 pm »
  • Security - Secured the client against some known cheats and exploits
Nope, exploit still works.

He meant FH cleo patch i guess.

First of all, Linux server on x64 machine doesn't run:
Code: [Select]
version `CXXABI_1.3.8' not foundStackOverflow says, that you had to set -static-libstdc++ and -static-libgcc flags.

Post your gcc -v info.

After downloading server and client stuff, i tried to join my server. First, what i've found, that client crashes, if server uses sprites. I'll check other things later, but I guess everything I wrote above is enough.

Check the sprites or something, in Aurora the sprites doesn't crash. Everything you wrote looks like uac issues.



PD: After an minute AFK, i've received a message: Error: A MEMORY check on your client timed-out.

And i've been kicked.

Same for me

SugarD

  • Argonath RPG Dev/Manager
  • Tester
  • Sr. Member
  • ****
  • Posts: 817
  • Karma: +37/-74
  • STOP IN THE NAME OF THE COLESLAW!
    • View Profile
    • Clan Xperience
Re: Update 0.1.0.17 (14/06/2016)
« Reply #6 on: June 15, 2016, 09:13:27 pm »
Code: [Select]
You don't have permission to access /Downloads/lu-0.1-installer.zip on this server.
?
Known issue someone else reported too. I notified VRocker about it. All we can do now is wait.

Same for me
I noticed that too. I think it may be a new UAC feature that had an unintended consequence.



Make sure you guys report the bugs on the bug tracker!!!
« Last Edit: June 15, 2016, 09:15:03 pm by SugarD »

VRocker

  • Liberty Unleashed Developer
  • Administrator
  • Full Member
  • ******
  • Posts: 342
  • Karma: +42/-15
    • View Profile
    • Madnight Software
Re: Update 0.1.0.17 (14/06/2016)
« Reply #7 on: June 15, 2016, 11:40:19 pm »
Fixed the download issue

Feck knows why the memory check times out. This on a linux server and how laggy are you? I might have to increase the time for the initial check.

As for the 'exploit', like i said i fixed some. I really cannot be bothered putting proper time and effort in so i patched some easy things.

As for the linux server, i guess adtec compiled it with a new GCC version. What OS are you running?
Windows server crashing... bleh.

Most of the fixes were done quickly when i had a sudden urge to fix things.


SugarD

  • Argonath RPG Dev/Manager
  • Tester
  • Sr. Member
  • ****
  • Posts: 817
  • Karma: +37/-74
  • STOP IN THE NAME OF THE COLESLAW!
    • View Profile
    • Clan Xperience
Re: Update 0.1.0.17 (14/06/2016)
« Reply #8 on: June 16, 2016, 01:23:18 am »
Feck knows why the memory check times out. This on a linux server and how laggy are you? I might have to increase the time for the initial check.
I'm getting the memory check on the Windows server, locally-hosted, the moment I minimize my game.

Atheros

  • Newbie
  • *
  • Posts: 24
  • Karma: +4/-5
    • View Profile
Re: Update 0.1.0.17 (14/06/2016)
« Reply #9 on: June 16, 2016, 09:35:17 am »
yeah im getting memory check kick too
i was counting and it happend after 30 seconds of afk

VRocker

  • Liberty Unleashed Developer
  • Administrator
  • Full Member
  • ******
  • Posts: 342
  • Karma: +42/-15
    • View Profile
    • Madnight Software
Re: Update 0.1.0.17 (14/06/2016)
« Reply #10 on: June 16, 2016, 03:17:36 pm »
Ohh so it happens when you minimise? That makes sense as minimising freezes the netcode for a bit so any integrity checking will time out. I'll look into this a bit more sometime this weekend.

Two solutions... don't minimise the game or run the game in window mode as that keeps the game running from what i remember


Ankris

  • Full Member
  • ***
  • Posts: 110
  • Karma: +29/-44
    • View Profile
Re: Update 0.1.0.17 (14/06/2016)
« Reply #11 on: June 16, 2016, 04:53:42 pm »
run the game in window mode as that keeps the game running

meh, happens even with windowed (i always play with windowed mode)

Benedani

  • Newbie
  • *
  • Posts: 17
  • Karma: +2/-0
    • View Profile
Re: Update 0.1.0.17 (14/06/2016)
« Reply #12 on: June 17, 2016, 02:12:36 pm »
I can't update my server, first it asks for MSVCP140.dll (in caps), then i got that from system32 and renamed it now it says
the application failed to run (0xC000007B)
whats the problem here?

Fun fact: At first I thought it was hackers messing with the server.exe

TurboGrafx

  • Full Member
  • ***
  • Posts: 235
  • Karma: +32/-33
    • View Profile
Re: Update 0.1.0.17 (14/06/2016)
« Reply #13 on: June 17, 2016, 02:39:09 pm »
This is what I'm talking about Vrocker!!

Simple updates is all that matters.

I will say that yes I am a XP user. Currently im in the process of upgrading. If what I am upgrading to becomes a success and is supported for LU/VCMP I will create a tutorial.

http://reactos.com/

I'm very pleased you have taken the time to update and very appreciative thank you Vrocker!! :D

VRocker

  • Liberty Unleashed Developer
  • Administrator
  • Full Member
  • ******
  • Posts: 342
  • Karma: +42/-15
    • View Profile
    • Madnight Software
Re: Update 0.1.0.17 (14/06/2016)
« Reply #14 on: June 17, 2016, 04:39:37 pm »
You need the Visual Studio 2015 redistributable: https://www.microsoft.com/en-gb/download/details.aspx?id=48145


 

© Liberty Unleashed Team.